API errors detected and affecting access to existing share links and new drop creation
Incident Report for CloudApp
Resolved
CloudApp is back online!
Posted 8 months ago. Nov 27, 2017 - 09:42 PST
Investigating
We are currently investigating this issue.
Posted 8 months ago. Nov 27, 2017 - 09:26 PST