Viewer outage
Incident Report for CloudApp
Resolved
This incident has been resolved.
Posted Feb 19, 2021 - 09:25 PST
Update
We are continuing to investigate this issue.
Posted Feb 19, 2021 - 09:24 PST
Investigating
We are currently investigating this issue.
Posted Feb 19, 2021 - 08:55 PST
This incident affected: Viewer.