Experiencing downtime
Incident Report for CloudApp
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 11:05 PST
Investigating
We are currently investigating this issue.
Posted Feb 22, 2021 - 10:58 PST
This incident affected: API.